Follow

Is my device compatible with the MERGE Cube?

Below is a list of devices that are RECOMMENDED with the MERGE Cube: 

  • iPhone 6 and newer
  • iPad Air and newer
  • iPad Pro (all)
  • iPad Mini 4
  • Google Pixel 
  • Google Pixel XL
  • LG One (M9)
  • Galaxy S8
  • Galaxy S8 Plus
  • Galaxy S7 Edge 
  • Galaxy S7

Below is a list of devices that are COMPATIBLE with the MERGE Cube: 

  • iPod Touch (6th Generation)
  • iPhone - 5S and SE
  • iPad Mini (2 & 3)
  • Nexus 9
  • HTC One (M9)
  • HTC One (M8)
  • LG G5
  • LG G4
  • Moto X (2nd Generation)
  • Galaxy S6 Edge
  • Galaxy S6
  • Galaxy S5

Below is a list of devices that are NOT COMPATIBLE with the Merge Cube: 

  • All Amazon Fire Tablets
  • iPhone 5 and older
  • iPod Touch 5th Generation 
  • Google Nexus 5X
  • Google Nexus 6P
  • Google Nexus 6
  • Google Nexus 5
  • HTC One M7
  • LG G3
  • Motorola Droid Turbo 2
  • Motorola Droid Maxx 2 
  • Moto E (2nd Generation)
  • Moto G (3rd Generation)
  • Galaxy Note 10.1 (2014 Edition)
  • Galaxy Note 4
  • Galaxy Note 5
  • Galaxy Galaxy J7

We recommend making sure that your phone is running the latest software:

  • Apple Devices: IOS 9 and newer
  • Android Devices: Android 6 OS (Marshmallow)

The best way to determine if your device is compatible is to search the iTunes or Google Play for Merge Th!ngs. If your device is compatible you will be able to download the app.

0 Comments

Please sign in to leave a comment.